Examining CVE-2017-9791: New Apache Struts Remote Code Execution Vulnerability

The Apache Struts framework is useful for building modern Java-based web applications, with two major versions, Apache Struts 1 and Apache Struts 2, released so far. Support for Apache Struts 1 ended in 2008 with the adoption of Apache Struts 2, which reached its first full release at the start of 2007. A Struts 1 plugin is available that allows developer to use existing Struts 1 Actions and ActionForms in Struts 2 web applications. A vulnerability has been found in this plugin that could allow remote code execution on the affected server, if used with Struts 2.3.x. (Versions 2.5.x are not affected.)
Post from: Trendlabs Security Intelligence Blog – by Trend Micro
Examining CVE-2017-9791: New Apache Struts Remote Code Execution Vulnerability